WK 5 – Device Data Dashboard (cont’d)

Running into some issues just trying to upload the sketch now with shiftr credentials rather than mosquitto.

First, thought I broke my nano as it stopped showing up as a visible port. After a quick google, I read to quickly press the reset button twice to get the bootloader running, that worked and I was able to see the board in Arduino IDE. Attempted to re-upload the new sketch, uploaded successfully but then the port proceeds to say [not connected].

I redid the reset, and uploaded the previous sketch with mosquitto info, and that seemed to work.

Tried again, and same thing, it uploads the sketch then disconnects…

Update: found the issue…

I had written this line of code –> String clientID = “thesis-clock-” + random(1, 10000);

I don’t think it liked the random number portion.

Next, I updated my data dashboard code to reflect the shiftr credentials, and made sure everything still worked properly.

I’m still working on the visual aspect of the sensor data as mentioned previously in the last blog post.

Leave a Reply